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Welcome 

DREAM Version 2.6 Software 
Version 2.6 software is primarily a maintenance release. At the same time a number of great new 
features have been added, mostly in direct response to users’ requests. 

Fairlight values all suggestions for new features, and reports of defective behaviour. A big thanks is 
due to all participating users, and we hope you enjoy using the updated software. 



Software Release Information DETAILS December 7, 2009 

DREAM II Version 2.6 Page 3 

Details 

This section will itemize the improvements in Version 2.6 software, and give brief instructions for 
using them.  

DREAM II Improvements 

Restore Multi-channel 
The following commands are used when your project contains clips with some channels missing. This 
can happen in many ways, but a common one is when a location recordist has taken many channels, 
but the video editor has used only one or two indicative tracks to cut the video. After the edit list is 
conformed, the audio editor needs access to all the original channels. 

Another instance is when you have recorded a multi-channel clip in Dream II, and cleaved it within 
the project. 

The system will match the audio file currently in the project with others stored on disks, and bring the 
latter into the project. The following commands are found in the Edit Menu above the Edit Screen. 

"Restore Multi-Channel" – Restores the missing channels of a multi-channel file, while matching edits, 
fades, clip level and clip EQ. Works with both interleaved media (e.g. a stereo wave file) and multiple 
mono media that are intended to be used together.  

To set criteria for searching and matching, click BWF in the Edit Menu, then choose one of the 
following: 

"Define BWF Search Folders" – Choose folders for use with the Restore Multi-Channel and Trace BWF 
Features. This new function builds a database of BWF metadata from all the selected folders. 

"Define Match Criteria" – This command allows you to refine the search for matching files. By default 
it matches timecode and record duration, but you can include reel, notes and other criteria. When you 
open this dialog, it shows which of the metadata are present in the clip selected in your project, which 
indicates their likely relevance in matching. 

"Trace BWF" – This tool provides a manual search interface. It shows which files Restore Multi-
Channel will find and attach to your original in the project. These files must reside in a folder 
previously set up in "Define BWF Search Folders". After the search returns results, you can alter the 
Matching criteria in the dialog box to see what effect this has. You can also select any of the files in 
this dialog, and click the Restore button to bring them into the project. 

Machine Control 
(Request number 693470) If you attempt to drop into record onto a vtr where the drop frame status 
does not match the current system setting you will see an error message: "Drop Frame mismatch", 
and the vtr will not go into record. 

File Handling 
BackupProjectToFolder can now optionally export video or not, and optionally choose to compress the 
video or keep it at its native format.  MFX3+ you can now choose to optionally convert all audio to 
either 16 or 24 bit when fufstuffing. This option is available in : Setup->General Preferences->Projects 

Compressed video pipeline. Improves performance when playing back DNxHD MXF and Quicktime files. 
This option is available in : Setup->General Preferences->Playback 

DR2 projects now store what the 'View -> TimeScale' format was when the project was saved and 
restores the projects 'View -> TimeScale'when the project is loaded again. 

Drag and drop MXF/Avid DNxHD files. (requires DNxHD License). 
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Export video and audio via AAF. Requires new AAF plugin. 

Media can now be dragged and dropped from read-only devices, such as a CD-ROM or DVD-ROM 
device. Media can also be dropped from non-Fairlight devices, such as a network device accessed via 
a URL, such as \\fs04\RAID\media ... This media is "temporary" which means it must be localised or 
fuf-stuffed before the project is saved. The project will prompt you to do this when you save. 

Pyxis and DR2 projects can now be offset (by time and tracks) when imported. 

MXF files are now read more efficiently. This will give faster, more responsive jog performance. 

Reduced the amount of memory used by each Quicktime placed on the timeline. This helps when 
there are lots of Quicktime videos on the timeline. 

Editing 
The ability to group clips. There are two new menu options in the edit menu to support this feature 
'Group Clips' and 'UnGroup Clips'. Grouping clips allows you to combine a number of clips on the 
timeline so they become one clip. This is useful when you have built up something like a sound effect 
with multiple clips, as you can than treat the multiple clips as one clip on the timeline afterwards. If 
the clips you group span tracks than you will get a separate group clip for each track and these new 
group clips will be linked together. The menu option 'Group Clips' only works on clips that have been 
explicitly selected via either a range or mouse selection, it does not group clips under the playhead as 
that would result in a group of one clip. In the future an option will be added to link clips together 
that are under the playhead.  

Consolidation has been improved to better handle reverse and stereo clips within MT projects. 

Now it only takes one undo to put clips back where they previously were after being moved by the 
mouse. 

Previously if you used the mouse to drag and drop clips on the timeline and some clips were dropped 
on the wrong track for their media type, you would get the message 'Clip type not supported on this 
track.'. And the dragged clips would disappear. The only way to get them back would be to than 
perform an undo. Now the undo is performed automatically so clips that were dragged and dropped in 
this situation will be back in their original place on the timeline. 

The hardware "back/front" registers are disabled in Loop Jog to avoid muting when changing EQ.  

Multi-channel Clip Display 
There is a new option in Setup -> General Preferences in the Options tab called 'Linked clips drawn as 
single clip (Layer Display Off)'. This makes linked clips appear as one clip when you are not displaying 
layering. 

Choose Dream II Monitor 
Previously Dream II always ran on the primary monitor in the system. There is a new registry option 
'Global Setup -> Display Monitor Number'. This allows you to specify a different monitor to the 
primary monitor for Dream II to start on. The value is the number of the monitor where you would 
like Dream II to run. 

Import/Export 
Improvements to allow Dream II to co-exist on an Avid Unity ISIS network.  

(Request number 693462) AES31 import now has the option to specify a track and TC offset. 

Dream II now plays 720p MXF/DNxHD files. 

Further improvements to allow Dream to play large FCP projects 

Previously some projects with multiple layers and fades could not be exported successfully to AES31 
or AAF projects. When trying to export to AAF, an error 8012011B was reported. 
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Analog Audio Level 
Added the possibility to configure the SX20 Analog Reference Level (needs SX-20 Core 2.0.22 and CC-
1 Core 382).  Specific reference levels can be configured using the relevant registry files in 
C:\Program Files\Fairlight\Dream II\SX20 Flash\. 

Crash Protection 
Improved support for recovering your project if Dream II crashes or the PC crashes/loses power. On 
top of the software exception project which is generated if Dream II does crash. Dream II also detects 
if it did not shutdown correctly last time. If this occurs and no software exception project was 
generated, the software asks you if you would like Dream II to try and recover your last project. This 
attempts to recover the project to the state it was in before the last edit occurred. 

Improved the detection of corrupted folder Info files. 

Displays 
Increased the size of the timecode display when displaying HMSF, as there are less characters being 
displayed so more space to increase the font size. There are now three sizes of font for the timecode, 
there used to be only two. With HMSF having the new largest font, HMSFSR the smallest. The rest of 
the timecode formats display at the old size. 

Reversed clips now have a new icon on them, instead of the SRC icon. 

View Statistics - more information available including the total number of bytes of audio (to estimate 
the space required for backup, for example). 

Xynergi Improvements 
Xynergi fader mapping now works better. You can change fader sets at any time and the mapping will 
restart for the new fader set, at the first fader. Pressing the currently mapping fader set will also 
move its active point back to the first fader in the set. Link groups are now displayed during fader set 
mapping, and are correctly assigned to one fader. Note that, immediately after creating a link group, 
its members will be individually assigned to faders (if mapped to a fader set before linking). 

Xynergi now allows selection of VCA groups for use in mixing. They are found by pressing the Bank 
Down button when displaying buses. Selection allows them to be included in Mix Copy, Punch, Prime 
etc. Double-pressing of VCA master buttons is also implemented, but not selection of a range by hold-
and-double-press. 

Double-pressing a Pad Mode button (Path, EQ, Dyn Aux) now locks the Zoom display on the screen. 
While it is locked, changing Pad mode will also change the Zoom display to match, while keeping it 
locked. Double-pressing a second time clears the Zoom display. 

The Xynergi set_source display now allows assignment to VCA groups. To use it, press and latch SEL, 
choose one or more tracks (or lives) then hold down set_source. If any selected paths are already 
assigned to one or more VCA groups, those groups will be illuminated. To assign all selected tracks or 
lives to a VCA group, press its button. Note: Set Source is not illuminated if a mixture of Tracks and 
Lives is selected. 

Bug fixes 
(#675079). Previously D10 MXF files containing frames that were too large could not be exported. 
Now the larger than legal frames are truncated. 

(#684508), Previously selected File->Export->Video File would de-select tracks if any tracks were 
armed, making it difficult or impossible to specify which tracks were required for export. 

(#716284), Previously Auditioning blanked out the Decklink output. 

Added correct persistence of the new bit-depth MT consolidation parameter. 
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ADR graphics did not appear on the decklink card. Bug introduced in v2.50a1.460. 

After Undo and Redo, certain parts of the system forgot that tracks were armed. Consequently some 
features did not work as expected, for example the selection of armed tracks on entry to the Arm 
menu.  

Bogus error message "Media 'FL_bounce...' identical to 'FL_bounce.." which appeared sometimes 
when bouncing removed. 

Fix associated with new MT project fuf stuff bit depth option. The option now applies to all MT 
projects, not just MFX3+ compatible. (#699531)Previously 32 bit audio in a DR2 project could not be 
saved into MT format. 

Fix for AES-31/AAF automation import for multiple files (automation is merged). 

Fix for Drag/drop of Thomson XML files (confusion with FCP XML). These are now only available via 
import. 

Fix with the incrementing of record seed names in a link group track if each track has a different 
record seed name. 

Fixed a bug that occured when attempting to a nudge a clip after using the track numbers menu to 
swap a track with another track. 

Fixed a bug where for some edit operations that affected the sound of a clip but not its position on 
the timeline (ie. reverse clip, clip based EQ) if you performed an undo to undo the edit operation the 
tracks cache was not being reload, so the clip sounded the same still unless you moved the timeline 
away and back again. This bug was introduced in 2.1 when the feature below was added: 'Now when 
you do an undo/redo Dream II only reloads the caches for the tracks that were changed unlike 
previously where all tracks caches were reloaded.  

Fixed a bug with Audiobase audition where on some machines the audition was always occurring on 
the first audio track. 

Fixed a bug with the importing of audio from Quicktime Ref files. If the audio in the Quicktime ref file 
was not the length of the video, than where there should of been silence the imported clip was 
getting rubbish audio.  

 Media which is hidden (not on the top layer) is now no longer included in AAF or AES31 exports.  

Includes a new version of the AAF plugin v1.0.8.2. This includes a fix to allow correct export of multi-
channel audio files to embedded AAF files. 

MXF/DNxHD and Mpeg2 4GB file offset bug fix. Problem seen in DNxHD and Mpeg2 MXF files greater 
than 4GB 

Previously a reversed or live SRC'ed audio clip would not be automatically converted when performing 
a SAVE-AS from a DR2 project to MT format. 

Previously Dream II would be very slow to open some MXF files containing 422P HL Iframe mpeg2 
data. 

Previously Dream II could not display/import Quicktime files that had an odd number of pixels for a 
width. This is due to YUV 422 only supporting an even number of pixels for a width. For Quicktime 
files with an odd number of pixels Dream II drops the last pixel. 

Previously if an mp3 was dragged onto the video track you would only get the right channel of the 
mp3 on the first audio track. Now the mp3 is moved down to the first audio track so you get all the 
channels, which is the same behavior as dragging a wave file onto the video track. 

Previously playing odd sized video files, in conjunction with -PRO2 command line option produced 
unexpected results.  

Previously some mpeg files (.mpg and .mvf) would snap to 1 frame too early on the timeline. 
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Previously the progress bar would not update (appear to be frozen) when backing up a project, with 
dv25 chosen as the destination format. 

Previously video capture could go out of synch, if video capture mode was turned on and left on whilst 
closing/opening or new project. 

Previously you could not load a MT format project from a read only device (e.g. a DVD) then perform 
a save-as to writeable device (e.g. local disk). 

Previously, if you have background media scan off, then importing a DR2 or Pyxis project did not 
automatically relink its media. 

Resolved a further issue with MT Fuf Stuff of reversed Clips when record handles were active. 
(previously the audio in the resultant MT was incorrectly offset). 

Saving to MT project format neglected to require FUF-stuffing for stereo audio referenced by mono 
(cleaved) clips.  

Time remaining calculated incorrectly when recording to mjpeg quicktime format. 

Undefined EQ bands in MT clips were not saved and loaded correctly. The default frequencies were 
wrong.   

When saving a project from DR2 to MT or MT-MFX3+ format, Dream II checks the track count first, 
before checking any other criteria. This is because there is no point performing the fuf stuff because a 
project with too many tracks cannot be saved to these formats. 
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